ABS and ESP sensors

Posted in the Dodge Sprinter Forum

Comments

Showing posts 1 - 20 of24
< prev page
|
Go to last page| Jump to page:
Mike

Grapevine, TX

|
Report Abuse
|
Judge it!
|
#1
Dec 13, 2010
 
I have a 2007 2500 Sprinter and the ABS and ESP lights are being displayed along with another light
which looks like a tire but it's not the tire sensor. I have power but the cruise control does not work. I have been told by a freightliner dealer that the ASB speed sensor/ESP cruise control is the problem. I was told the part is around 7.00 but the total repair is going to run around $627. It's 3 hours diagnostics and 2 hours to replace necessary part. Is this reasonable. Sounds like I'm paying a lot for labor?
Mark

Idaho Falls, ID

|
Report Abuse
|
Judge it!
|
#2
Dec 13, 2010
 
Hey Mike,
Well, This definately sounds like a wheel speed sensor, 3 hours to diagnose is totally rediculous. Any starscan or starmobile made for Chrystler diagnostics will show exactly which speed sensor is bad. The problem is that they are all totally different in design. Both rears are different, and the fronts may or may not be the same part. These are really easy to install as long as they aren't broke off in the sensor tube that leads down into the tone ring. They are easy to connect and work on once the wheel is off and they're off the ground. It really does sound like you're being taken for a ride on labor and diagnostics. Oh, but there is no way this wheel speed sensor will cost only 7 dollars, you will be paying around $100 for the right part. Sounds like they're selling you a brake wear sensor instead...Sheesh....sorry about the bad luck Mike. Hope you have a Merry Christmas.
dan

United States

|
Report Abuse
|
Judge it!
|
#4
Dec 16, 2010
 
]just got my sprinter back from having the front brakes done, now the abs, esp, and traction control warning lights are going off and the cruise dosent work. everything worked fine when i took it in. did they damage the speed sensors when they did the brakes?
Mark

Idaho Falls, ID

|
Report Abuse
|
Judge it!
|
#5
Dec 17, 2010
 
The ABS and Electronic Stability are dependent on the wheel speed sensors to control the amount of braking applied to each wheel. Without this information, the ABS Module disables cruise control and will set 3 very annoying lights. I would say they may have messed with the routing of your speed sensor cables (Very common practice when replacing front struts) otherwise it's hard to imagine how the sensors could have been damaged, but I would say that's a definate possibility.
TurnipTruck

Emmaus, PA

|
Report Abuse
|
Judge it!
|
#6
Dec 18, 2010
 
Check your brake pedal switch.
dan

United States

|
Report Abuse
|
Judge it!
|
#7
Dec 20, 2010
 
now they changed it to replace brake pedal switch and clean all 4 sensors. I'm thinking they probably need to only clean the front ones. but for all that they want $400.00 plus I paid for a $100.00 diagnostics fee. and the front brake job (pads disks sensors & calipers) ran just under 1k.
sound about right?
Kurt

Canby, OR

|
Report Abuse
|
Judge it!
|
#8
Dec 20, 2010
 
TurnipTruck wrote:
Check your brake pedal switch.
TurnipTruck:No Cruise Control Brake Lights on all the time Brake Pedeal Switch ($28) was my culprit,thanks for your posting.
vadim

United States

|
Report Abuse
|
Judge it!
|
#9
Jan 23, 2011
 
push the wheel speed sensor all the way in when you install it. it self adjusts as you drive. had the same problem with mine. this fixed it. hope it helps.
Greg

Chicago, IL

|
Report Abuse
|
Judge it!
|
#10
Sep 11, 2011
 
Mike wrote:
I have a 2007 2500 Sprinter and the ABS and ESP lights are being displayed along with another light
which looks like a tire but it's not the tire sensor. I have power but the cruise control does not work. I have been told by a freightliner dealer that the ASB speed sensor/ESP cruise control is the problem. I was told the part is around 7.00 but the total repair is going to run around $627. It's 3 hours diagnostics and 2 hours to replace necessary part. Is this reasonable. Sounds like I'm paying a lot for labor?
The cruise control want be working till you not gonna fix light it is happening is my sprinter to if u got to much oil and u can see on dash Hi, oil cruise dont work if u got esp turn of cruise dont work and any other light which appear on dash And I thing anything over 450 is the rip off
JOE

Mineola, NY

|
Report Abuse
|
Judge it!
|
#11
Sep 22, 2011
 
ESP LIGHT ON FOR EVER , THIS IS THE WORST COMPUTERIZED VAN I GOT (YOU FART AND A NEW SENSOR COMES ON) PARTS ARE SO EXPENSIVE ,AND SEEMS LIKE VAN IS ALLWAYS IN REPAIR SHOP

Since: Apr 11

United States

|
Report Abuse
|
Judge it!
|
#12
Jan 18, 2012
 
I know this is off topic but if you want to pull off you Dpf filter and disable egr valve give custom spooling a call they can do it, 2007 sprinter Dpf filter is about 3000$ and for 695$ I got more power and reliability out of my sprinter
Nai

Newburgh, NY

|
Report Abuse
|
Judge it!
|
#13
Feb 8, 2012
 
I went to the alignment shop and when the truck was done my ESP light came on and its been on ever since then. what could have caused this problem? Considering the wheels were never removed during the process.
Nai

Newburgh, NY

|
Report Abuse
|
Judge it!
|
#14
Feb 8, 2012
 
Sorry guys I forgot to mention that I have an 2008 dodge sprinter 2500 170 wheel base.
billy blue balls

Lexington, SC

|
Report Abuse
|
Judge it!
|
#15
Feb 10, 2012
 
Nai wrote:
Sorry guys I forgot to mention that I have an 2
008 dodge sprinter 2500 170 wheel base.
they could have damaged the sensor wiring,also if they pulled on the sensor wiring it could have disturbed the gap setting between the sensor and tone wheel on hub
Nai

Newburgh, NY

|
Report Abuse
|
Judge it!
|
#16
Feb 11, 2012
 
Thanks Bill. But guess what, after driving all week doing about 1500 miles after the alignment Wednesday. Well today Saturday I drove the truck for about 2 miles to a friends house and back and the ESP light did not appear again. I am thinking after a number of restarts and mileage, the computer figured it was an error because of the process of how the alignment was done, with the wheels off the ground at times and the engine being restarted to place the steering lock on the truck for steering precision. I HOPE THAT WAS THE PROBLEM AND IT SOLVED ITSELF . THANKS BILLY
dirk

Brasher Falls, NY

|
Report Abuse
|
Judge it!
|
#17
Jul 28, 2012
 
i replaced the cruise control switch in the steering column and when i got done the esp light came on on the dash. what's up with that? i have an 08 dodge 2500 diesel sprinter. thanks alot for any help you may have
billy blue balls

Lexington, SC

|
Report Abuse
|
Judge it!
|
#18
Jul 29, 2012
 
try this first,start vehicle and turns wheels full right than continue to turn to full left and bring back to center with wheels straight ahead and shut off ignition wait 30 seconds and restart,see if lamp goes out
jerry

Derry, NH

|
Report Abuse
|
Judge it!
|
#19
Nov 8, 2012
 
My 2007 freightliner sprinter was tow by the front end to the dealer for the igition switch was defective and know the abs and the esp light is on was this caused by towing the truck ?
David

Cincinnati, OH

|
Report Abuse
|
Judge it!
|
#20
Jun 14, 2013
 
A day after I got my 2004 Sprinter van back from the repair shop with all new brakes, the gear selector will not go into drive unless I use a pencil to push that button. Also my ABS and ESP lights are on. I'M ASSUMING THE COMPUTER THINKS THE BRAKES WERE NOT INSTALLED RIGHT, OR MAYBE THE SENSORS WERE NOT PUT ON CORRECTLY WITH THE NEW BRAKE PADS.. DOES ANYONE HAVE ANY ADVICE?
billy blue balls

Lexington, SC

|
Report Abuse
|
Judge it!
|
#21
Jun 14, 2013
 
David wrote:
A day after I got my 2004 Sprinter van back from the repair shop with all new brakes, the gear selector will not go into drive unless I use a pencil to push that button. Also my ABS and ESP lights are on. I'M ASSUMING THE COMPUTER THINKS THE BRAKES WERE NOT INSTALLED RIGHT, OR MAYBE THE SENSORS WERE NOT PUT ON CORRECTLY WITH THE NEW BRAKE PADS.. DOES ANYONE HAVE ANY ADVICE?
....faulty brake lamp switch will cause this issue,switch has more than one circuit,brake lamps may operate but abs and trans controller may not see the input of the switch thus not allowing the shifter to operate

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Showing posts 1 - 20 of24
< prev page
|
Go to last page| Jump to page:
Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

8 Users are viewing the Dodge Sprinter Forum right now

Search the Dodge Sprinter Forum:
Topic Updated Last By Comments
Dodge Sprinter MPG: Real World Numbers (Jul '06) Apr 17 Adrian 137
Sprinter Engine failures (Mar '08) Apr 4 Gary 148
Sprinter wont start (Nov '08) Apr 4 Bromo911 38
Aux heater Apr 4 Walter 3
sprinter transmission shifting issue (May '13) Apr 2 briody 7
Loss of engine power (Oct '09) Apr 2 briody 65
Dodge sprinter rust problem (Nov '09) Apr 1 Unhappy Sprinter Owner 58
•••

Buy a New Car


Zipcode:
•••
•••
•••