dhyde

United States

#41 Feb 10, 2013
Johnnyk wrote:
I think that it is total crap that Chevy allows this defect to continue. I changed 60 dollars in parts and fixed the problem. When Chevy wanted 4500 dollars to fix it.
What was the part/solution?
Jon B Dudley Shoals N C

Lillington, NC

#43 Feb 20, 2013
Sorry everyone but im new to the internet scene. I have a working knoledge of cars and do alot of the work myself. I ordered a crate engine its a 347 stroker. It busted a piston so i took it and had it fixed. Now with close to 4000 miles on the clock when get into the throttle my oil pressure drops very low then when i let out of it the pressure comes back up. Could i need a deep sump oil pan or is it my lifers.Could they have been damaged when piston busted and went through out the heads? Or is the oil pump sucking the pan dry? Any answers would be appreciated. Thanks.
Rajesh

Riyadh, Saudi Arabia

#44 Feb 26, 2013
I am having trial blazer 2009 model. At idle condition the oil pressure goes down and then picks up when accelerator is given. But mainly during acceleration at low speeds and deacceleration at low speeds around 40 to 60 kms/hr, occassionally there was sound coming from Engine. Even I left at Chevrolet service station at Dammam, saudi Arabia and they are recommending to change the oil pump. They are not confirming whether the problem will get solved when oil pump is changed. Does someone experienced such problems. If so pls provide solution and your recommendations
randy

Round Rock, TX

#45 Apr 16, 2013
Rick Norfolk VA wrote:
I have the same problem with the oil pressure randomly dropping on my 02 trailblazer. Before I get my mechanic to go on a wild goose chase, did anyone get this problem resolved?
I have the same problem on my 02 trailblazer and It seems to happen when there is excessive crankcasedropping e. Take off your oil filler cap while the engine is running and see if there is pressure. If so leave the oil filler cap off with engine still ideling and go. atch your oil pressure gage and see if it stops dropping erratically . The 4.2 litre I6 motors in the trailblazers do not have a pcv valve but instead use a hose under the air box that mounts to the throttle body. Its in the front of the air box and goes the the valve cover. Not sure if it could be clogged so I'm about to check it out. Hope this helps.
randy

Round Rock, TX

#46 Apr 16, 2013
randy wrote:
<quoted text>
I have. he same problem on my 02 trailblazer and It seems to happen when there is excessive crankcasedropping e. Take off your oil filler cap while the engine is running and see if there is pressure. If so leave the oil filler cap off with engine still ideling and go. atch your oil pressure gage and see if it stops dropping erratically . The 4.2 litre I6 motors in the trailblazers do not have a pcv valve but instead use a hose under the air box that mounts to the throttle body. Its in the front of the air box and goes the the valve cover. Not sure if it could be clogged so I'm about to check it out. Hope this helps.
Sorry suppose to say crankcase pressure .
randy

Round Rock, TX

#47 Apr 16, 2013
randy wrote:
<quoted text>
Sorry suppose to say crankcase pressure .
Actually I have a correction on my previous post. Its excessive vacuum on the crank case not pressure. Not sure what's causing this but ill update when I find out.
John

Durham, NC

#48 Apr 24, 2013
no solutions to this!?
john a verrier

Cranford, NJ

#49 Apr 24, 2013
jav junk them all
randy

Round Rock, TX

#50 Apr 30, 2013
john a verrier wrote:
jav junk them all
Buy an oil filler cap and cut a hole in the top and attach a filter of some kind on top and problem solved.
Dave in FL

Orlando, FL

#51 May 14, 2013
I may have a solution for some - this same problem existed in my '02 for almost 2 years until I had the fan clutch replaced for an unrelated problem. The low oil pressure indication has not returned. Someone else about a year ago suggested this would correct the problem - but I just looked this up today. My fan clutch had not worked in several years but here in Florida (no hills) it really didn't matter. When I drove out to Idaho, the transmission fluid overheated and a local mechanic did a great job of installing an aftermarket fan clutch. I hope this helps some of you out there. With the exception of gas milage, I like my '02 TB - it now has 190K miles and still runs great! Good luck everyone ...
Jake

Fort Smith, AR

#52 May 15, 2013
DMS119 wrote:
i have an 02 trailblazer and the reduced engine power light came on every morning during the winter and it took forever for the truck to warm up. I was told to replace the throttle body and I did that. The light stayed off until the temp erature dropped below fifty degrees. Now the service engine light is on and the rpm odometer drops while I am driving. Sometimes the truck will completely shut off and other times it just slows down. I was told to replace the 02 sensor. I don't know what to do anymore. If anyone has any suggestions, please let me know.
My 2002 trailblazer would have issues with RPM gauge during idle. Engine would rev and slow down, rev and slow down, rev and slow down. Sometimes it would just die at a stop light after it rev'ed up then dropped. Hesitated after hitting the gas constantly from a full stop to where it would sometimes die. Cruise control would never work and service engine light never went off. Changed spark plugs cleaned throttle body, nothing. Codes said camshaft position sensor failing.$30 part took five minutes to replace. Everything has leveled out and running very smooth.
mike 6

Moncks Corner, SC

#53 Jun 4, 2013
my 2004 trailblazer has fine oil pressure while normal acceleration is occuring,soon as i stop at red light,it drops to about 20..
Will

Holualoa, HI

#54 Jun 12, 2013
so has anyone found out what is wrong with the oil pressure dropping? i have a 2002 tb. i change the oil pressure sensor, did the oil change and still same thing happening. i did notice oil on the connector so i cleaned that aswell. still no change. i brought it to the rip offs and i paid them to tell me my tb is is ok and within specs. please did anyone solve this mysterious problem?
Kathie

Pine Grove, CA

#55 Jun 12, 2013
I too have the same problem with my 2003 Trail Blazer. Did it a couple of months ago and then quit. Started again 2 days ago and now when it get down to low rpms it dies.........starts right back up and pressure resumes to normal..........
Jenah Hamilton

Oklahoma City, OK

#56 Jun 18, 2013
Johnnyk wrote:
I think that it is total crap that Chevy allows this defect to continue. I changed 60 dollars in parts and fixed the problem. When Chevy wanted 4500 dollars to fix it.

What part did you replace?
Debi

Dayton, OH

#57 Jun 23, 2013
I also am having the same problem we have an 2002 S10 truck and after the engine warms up the oil pressure drops and engine light comes on apparently GM needs to fix the issue! I have been told oil pressure sending unit? If so did it fix the issue?
kennethslay

Jacksonville, FL

#58 Jul 14, 2013
Johnnyk wrote:
I think that it is total crap that Chevy allows this defect to continue. I changed 60 dollars in parts and fixed the problem. When Chevy wanted 4500 dollars to fix it.
how???
kennethslay

Jacksonville, FL

#59 Jul 14, 2013
could you tell me how and what parts i need to chang i need it fixed please.you can e-mail me at kennethslay55@gmail.com please
Low oil pressure

Dammam, Saudi Arabia

#60 Jul 17, 2013
I have 2006 LT Trailblazer , in Saudi Arabia where the weather temp at start up is 55 C , even-though i have the same problem as described by all.

Changing the pressure sending unit wont any value. the tick tack sound keep running when the gauge indicate low pressure which drives you to start thinking that your engine going to fail due to lack of lubrication.
I think Chevy has a serious technical issue and somebody have to address it directly.

in Saudi Arabia, dealers doesn't care, they care about money collection only.
Cesar

Goshen, IN

#61 Sep 4, 2013
Yup! I have 03 Trailblazer, and the same thing here about the oil gauge, but it just started a month ago. So it looks like there is no worries about blowing the motor. I almost traded it in, lol honestly i love my blazer but im getting tired of putting money in it

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
2003 Chevy Trailblazer will not start (Jul '09) 37 min Cyrill 42
2004 Trailblazer won't rev over 3000 rpm (Apr '08) 18 hr robb10 8
Transmission in my '03 Trailblazer dead (Sep '06) Sun tina 81
Car shuts off when A/C on (Jul '07) Sep 25 lateefahmed 102
2002 Trailblazer Problems--LOTS !! (Aug '07) Sep 23 bob 36
Trailblazer gas mileage (Mar '06) Sep 22 Cman1996 108
2003 TB low beam headlights keep going out (Sep '08) Sep 17 Danman 73

Chevrolet TrailBlazer People Search

Addresses and phone numbers for FREE