francis

Australia

#81 Jun 2, 2012
alternatore is the prob
diamonddave

Nelson, Canada

#82 Jun 23, 2012
wow(or should i say 'damn'), just bought an 05 aveo, that had the timing belt changed at 67000km(current kms), plus a top-end rebuild. anyway, runs nice now. So,Tony565565, you seem to b the god of aveos! i've read all ur advice...awesome u gave it up, and thanks. So, when should i gittr-dun again to avoid a personal hell, and anything else! thanks in advance dude! u rock! dave in nelson,BC,Canada
LaurenANDJosh

Warren, MI

#83 Jul 11, 2012
If anyone is selling their Aveo let me know, i am rly wanting to buy another one. I already have an 04 Aveo and i LOVE it!! only 77,000 miles:))♥
If Selling Email Rurouni_josh@wowway.com thanks
LaurenANDJosh

Warren, MI

#84 Jul 11, 2012
BlueSkyAveo2004 wrote:
<quoted text>
Yes!!! I am!!! It's been happening for about 2 years. I've been the only owner of my car. It happens even on smooth surfaces. I had my brakes checked and new brake pads put in but it STILL does it. The brakes catch a little but they still work. I've had dreams where my car won't stop, so it does bother me. And yes, if I switch off and then back on it stops and then sometimes starts up again.
Any advice?
ktmcghee@gmail.com
Easy, it happened to my car too but if yu check the owners manual it means your gas cap is not on tight enough. Try turning it to hear atleast 4 or 5 clicks and close the cap as hard as possible and it should fix it.
Nick

Virginia Beach, VA

#85 Jul 21, 2012
100% about copper core spark plugs. I bought an Aveo with 60,000 miles on it and changed the oil and spark plugs after buying it. Initially, I used the platinum spark plugs because they are "always" better. Wrong! The Aveo immediately had misfire issues. Check Engine light came on. I pulled the codes - transmission and engine knock codes. Googled the codes and Chevy issued a TSB for them recommending complete replacement of all valves and valve seats (~$1,200 to $2,000 repair). I found another post saying just swap out the spark plugs for copper core and maybe throw a little Marvel Mystery Oil in the crankcase for good measure - the car drives like a dream now. Some cars are tuned to run on copper core - Daewoo apparently did so for what became the Aveo.
Gio

Denver, CO

#86 Jul 22, 2012
Changing copper spark plugs with every other oil change seems like too much trouble and expense to me. I haven't changed my plugs in 3 years. Never changed paper air filter, just cleaned it every couple years. I get 30mpg hwy in Denver.
2004, 120000mi, 3rd timing belt, 3rd thermostat+housing (now a $100 metal one), 4 times resurfaced brake rotors, 3rd valve cover gasket, installed cruise control, 2nd O2 sensors, 2nd gas cap, replaced exhaust valves when 1st timing belt snapped.
Gio

Denver, CO

#87 Jul 22, 2012
By the way, it appears the Daewoo Lanos that came stock with cooper core spark plugs and early model Chevy Aveo with platinum (or was it Iridium) spark plugs have different part numbers for the ignition coil Ex: 2002 Daewoo Lanos MasterProŽ Ignition Coil
Part# 2-50018 vs. 2004 Chevy Aveo MasterProŽ Ignition Coil Part# 2-50094. So be informed, not all things are the same.
Morgan

United States

#88 Aug 1, 2012
I have a 2005 chevrolet aveo with the multi cylinder random misfire. already did the timing belt and all the plastic parts a year ago. recently in the hold light started blinking in the check engine light started blinking and it runs like crap in idle. i replace the spark plug wires and coyle and spark plugs. when I hook it to the computer from the auto parts store it tells me that I have a multi cylinder random misfire. I don't know which direction to go with it next can someone help.
starmike

Arouca, Trinidad and Tobago

#89 Aug 1, 2012
your problem is 2 things, have your throttle body cleaned with throttle body spray just like car cleaner, use maybe half of the can.
and the other main thing is your spark plugs or wires, check or change wires ,they suck.i have that problem since my first post ,
mine was blinking every 20 mins, i changed plug wires and cleaned throttle body, and it stopped..until t-body get dirty again.. just clean with spray
please note i am not a GM CERTIFIED MECHANIC..
I HAVE A 2006 AVEO
HOPE IT HELPS YOU
cdiceberg

Coffeyville, KS

#90 Aug 4, 2012
09 aveo a/c has a noise and barely cool
starmike

Arouca, Trinidad and Tobago

#91 Aug 4, 2012
cdiceberg wrote:
09 aveo a/c has a noise and barely cool
the idle pulley maybe defective..
next to ac ..
i changed mine . had same problem if ac is off noise lessens or none
when on . much louder
put ear near ac and switch on and rev car slowly. check where noise is coming from..
hope it helps
starmike@wowmail.com
Paul

Abilene, TX

#92 Aug 18, 2012
Andrea, so did you ditch the aveo or run it into a wall. Ive had an aveo since 2004. I've changed the timing belt twice. The first time was because it broke breaking valves and all kinds of stuff having to get a brand new head costing me $1,800 plus. Just got bck from 3,000 mile road trip in the same car from TX to Kansas to Ohio and back. Car still running great, that God. But I do not recommend that anyone buy this car. Friend of mine owns a Midas shop and he is always working on Aveos.
Brandon

Hilton, NY

#93 Aug 19, 2012
I have a 2004 Chevy Aveo with 81,182 miles on it. It has been a decent car. I need to get the timing belt and water pump replaced ASAP as it has not been done yet. I am planning on doing that within the next week and a half. It has been a great car and I hope to get another 100,000 miles out of it.
Sharon

Baton Rouge, LA

#94 Aug 23, 2012
"The Hold light started flashing in my 2009 Chevy Aveo last night on my way hold and it was still flashing when I got in it this morning. The book says to get the transmission checked...what am I looking at when I take it to be checked?"
george

Bloomingburg, NY

#95 Sep 1, 2012
actually i think my 2004 aveo is one of the most reliable cars ive owned, and ive owned many!(at least 30 cars). The car has just turned 250,000 miles and still runs perfect. no problems, just normal maintenance items. Looking forward to 300,000 or more miles!
starmike

Arouca, Trinidad and Tobago

#96 Sep 1, 2012
Morgan wrote:
I have a 2005 chevrolet aveo with the multi cylinder random misfire. already did the timing belt and all the plastic parts a year ago. recently in the hold light started blinking in the check engine light started blinking and it runs like crap in idle. i replace the spark plug wires and coyle and spark plugs. when I hook it to the computer from the auto parts store it tells me that I have a multi cylinder random misfire. I don't know which direction to go with it next can someone help.
normally that stops the problem, ignition wires & plugs /clean thr-body ..and check map sensor ,clean it..
i do this all the time every couple mths
hope it helps
Frank the Ferret

Chantilly, VA

#97 Sep 4, 2012
I have an '07 Aveo, bought used with 23K on it, now at 86K. Noticed some things in this thread that have been true with my car, also.

First, can't emphasize enough the need to have the timing belt changed about every 50K or so. These are infamous for failing ahead of their recommended 60K maintenance point. Swap out the water pump too while you're in there.

Getting that "bucking" engine issue when accelerating? My issue was that the valve cover gasket was leaking and oil was running into the plug wells, ruining the wires. I wasn't getting a check engine light, but #4 cylinder was misfiring. A new set of wires and a replacement gasket took care of that.

To keep things running smooth, I use Lucas fuel system cleaner about every four fillups. I've recently begun experimenting with Marvel Mystery Oil in the fuel (don't laugh) and noticed a slight increase in my MPG. Maybe it works. Maybe it's my imagination. Either way, the cranky little 1.6 appears to appreciate it, as it's running quietly and smoothly.

Oh, and do check your trans fluid -- mine went dirty black at about 38K. Had my tech do the BG trans fluid service, and ATF is nice and red still at 86K.
Richard

Lubbock, TX

#98 Sep 13, 2012
Wow, just read every one of these post, I wish it wasn't so cold outside, I would go try a few of these things out!
patrice

Big Sky, MT

#99 Sep 18, 2012
has changing to copper spark plugs and thinner filter worked well for others who tried it here?
If spray carb cleaner to clean throttle body, how do you do it without ruining the sensors. Is it safe to turn on car and press gas down to open butterfly then spray cleaner into tb?
Vtvintner

Colchester, VT

#100 Sep 23, 2012
I have a 2006 Aveo...every couple of months it starts throwing 2135 codes and hesitating. I take off and clean the throttle body, then it goes away.
The Chevy dealership says I have to replace the throttle body and gas pedal to end this. I also just put in new NGK original plus, but that didn't help either...any comments ?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Aveo Discussions

Title Updated Last By Comments
Aveo Exterior Door Lock Question. Please Help! (Sep '08) Sep 27 aveo2005 68
Trouble filling gas tank (Nov '06) Sep 17 Meg vega 442
2011 Chevrolet Aveo LT Sep 14 kim roberts 1
Aveo 2004 car alarm Sep 12 Angela 1
2010 Aveo Coolant Circulation Issues - Overheating Sep 11 flood404 3
chevy aveo won't turn over (Jul '13) Sep 9 William popow 12
09 Chevy aveo won't start (Feb '13) Aug '14 Irfan 12

Chevrolet Aveo People Search

Addresses and phone numbers for FREE