Acura TL Navi screen problem

Posted in the Acura TL Forum

Johnny-Welson

Ottawa, Canada

#1 Jul 13, 2009
Hi, I have an Acura TL 2005. Since yesterday, I dont know why the NAVI screen do not turn on. The radio play but the Navi screen stay black. Any Idiea what can make this happen ? Thank you

johnny-welson.fleurme@forces.g c.ca
Lily

Clovis, CA

#2 Sep 23, 2009
Johnny-Welson wrote:
Hi, I have an Acura TL 2005. Since yesterday, I dont know why the NAVI screen do not turn on. The radio play but the Navi screen stay black. Any Idiea what can make this happen ? Thank you
johnny-welson.fleurme@forces.g c.ca
I have the same problem with my 2005 Acura TL. Please let me know how you resolved the problem. Thanks.
Dan

Brea, CA

#3 Jul 29, 2011
I have the exact same problem with my 2005 TL. Let me know also.
Pasha

Toronto, Canada

#4 Oct 30, 2011
Hi there,
I have the same problem now.
Screen doesn't turn on and top display does not show any radio signal digits or anything other than thermometer and clock.
I checked and changed the necessary fuses in internal and external box and I even disconnected the battery.
Now my navigation system is locked and I have no screen to unlock it.

please if anyone have a solution let me know!

thnx

alipasha@sympatico.ca
Rexfordsirmans

United States

#5 May 23, 2012
I have had the same problem for at least a year. No display. Only the radio works. Has anyone figured out how to fix this?
Mart

Rigaud, Canada

#6 Jan 26, 2014
Somebody resolve thaïs problem????
Martinlalonde

Montréal, Canada

#7 Jan 27, 2014
I have the same problème today ..
midou

Montréal, Canada

#8 Mar 13, 2014
i have the same problem with my acura mdx 2007 the navigation screen stay black and the radio work please let me know how resolved this problem thanks
Lusty

Medford, MA

#9 Apr 6, 2014
I have the same issue, did anyone find a fix?
guy

New York, NY

#11 Aug 10, 2014
back nevi unit is no good
Antonio

Rancho Cordova, CA

#12 Sep 9, 2014
Most likely it's going to be the navigation unit. Alpine repairs the unit for $360.
josh

Troutville, VA

#13 Oct 27, 2014
Antonio wrote:
Most likely it's going to be the navigation unit. Alpine repairs the unit for $360.
So I just bought a 2005 acura tl and the navigation was working but has since started to show only the "acura navigation" screen how likely is it that this is the trunk unit?
AuntEm

Sarahsville, OH

#14 Oct 27, 2014
Lily wrote:
<quoted text>
I have the same problem with my 2005 Acura TL. Please let me know how you resolved the problem. Thanks.
It's the laser assembly located in the unit in the trunk. It needs to be disconnected and sent to Alpine in California.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Acura TL Discussions

Title Updated Last By Comments
More Advice On Acura TL Transmission Failures A... (Apr '09) Nov 17 TRich 279
CHASSIS/BODY INTEGRITY - 2004 Acura TL (Mar '07) Jul '14 KAL 2
acura TL 2005 brakes and gear shifting (Jun '06) Jul '14 Melissa 130
droning noise while driving on a highway (May '14) May '14 ron 1
Major Pain With BlitzSafe and Logjam Electronics (Apr '07) Mar '14 tammie 16
starting car when battery is dead and can't ope... (Dec '13) Mar '14 HAHAHAHA 2
daily messages - in car (Jan '14) Jan '14 RUSSELL TL 1

Acura TL People Search

Addresses and phone numbers for FREE