Comments
1 - 10 of 10 Comments Last updated Sunday Aug 10
Johnny-Welson

Ottawa, Canada

|
Report Abuse
|
Judge it!
|
#1
Jul 13, 2009
 
Hi, I have an Acura TL 2005. Since yesterday, I dont know why the NAVI screen do not turn on. The radio play but the Navi screen stay black. Any Idiea what can make this happen ? Thank you

johnny-welson.fleurme@forces.g c.ca
Lily

Clovis, CA

|
Report Abuse
|
Judge it!
|
#2
Sep 23, 2009
 
Johnny-Welson wrote:
Hi, I have an Acura TL 2005. Since yesterday, I dont know why the NAVI screen do not turn on. The radio play but the Navi screen stay black. Any Idiea what can make this happen ? Thank you
johnny-welson.fleurme@forces.g c.ca
I have the same problem with my 2005 Acura TL. Please let me know how you resolved the problem. Thanks.
Dan

Brea, CA

|
Report Abuse
|
Judge it!
|
#3
Jul 29, 2011
 
I have the exact same problem with my 2005 TL. Let me know also.
Pasha

Toronto, Canada

|
Report Abuse
|
Judge it!
|
#4
Oct 30, 2011
 
Hi there,
I have the same problem now.
Screen doesn't turn on and top display does not show any radio signal digits or anything other than thermometer and clock.
I checked and changed the necessary fuses in internal and external box and I even disconnected the battery.
Now my navigation system is locked and I have no screen to unlock it.

please if anyone have a solution let me know!

thnx

alipasha@sympatico.ca
Rexfordsirmans

United States

|
Report Abuse
|
Judge it!
|
#5
May 23, 2012
 
I have had the same problem for at least a year. No display. Only the radio works. Has anyone figured out how to fix this?
Mart

Rigaud, Canada

|
Report Abuse
|
Judge it!
|
#6
Jan 26, 2014
 
Somebody resolve thaïs problem????
Martinlalonde

Montréal, Canada

|
Report Abuse
|
Judge it!
|
#7
Jan 27, 2014
 
I have the same problème today ..
midou

Montréal, Canada

|
Report Abuse
|
Judge it!
|
#8
Mar 13, 2014
 
i have the same problem with my acura mdx 2007 the navigation screen stay black and the radio work please let me know how resolved this problem thanks
Lusty

Medford, MA

|
Report Abuse
|
Judge it!
|
#9
Apr 6, 2014
 
I have the same issue, did anyone find a fix?
guy

New York, NY

|
Report Abuse
|
Judge it!
|
#11
Sunday Aug 10
 
back nevi unit is no good

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Other Recent Acura TL Discussions

Title Updated Last By Comments
CHASSIS/BODY INTEGRITY - 2004 Acura TL (Mar '07) Jul 31 KAL 2
More Advice On Acura TL Transmission Failures A... (Apr '09) Jul 27 boogie 273
acura TL 2005 brakes and gear shifting (Jun '06) Jul '14 Melissa 130
droning noise while driving on a highway May '14 ron 1
Major Pain With BlitzSafe and Logjam Electronics (Apr '07) Mar '14 tammie 16
starting car when battery is dead and can't ope... (Dec '13) Mar '14 HAHAHAHA 2
daily messages - in car (Jan '14) Jan '14 RUSSELL TL 1

Search the Acura TL Forum:

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••
•••